domingo, 11 de julio de 2010

Crear un gráfico de Cascada o Waterfall

Excel posee muchos tipos de gráficos predeterminados (ver tipos aquí) y por ello es una herramienta muy utilizada para la visualización de datos. Un gráfico bastante utilizado que no está incluido en el paquete estándar, es el gráfico de Cascada. Este gráfico es muy conveniente para explicar la variación entre un valor inicial y un valor final.

Un buen ejemplo para el gráfico de cascada es cuando tenemos un valor inicial y otro final como por ejemplo el número de unidades vendidas el mes anterior y el del mes actual. Para explicar la variación entre estos dos valores se pueden definir varios conceptos positivos o negativos que llevan del valor inicial al final.

En este artículo explicaré como podemos crear un gráfico de Cascada utilizando uno de los tipos de gráficos incluidos con Excel.


Veamos el ejemplo



Tenemos una lista con dos valores uno inicial y otro final y cinco variaciones que explican la diferencia entre los dos valores.


Tomaremos como base de nuestro gráfico el tipo de gráfico de barras apiladas incluido en Excel.


Para realizar el gráfico de cascada necesitaremos agregar algunas columnas auxiliares que serán utilizadas en nuestro gráfico. La columna Series1 muestra el valor que se encuentra entre el valor 0 y el comienzo de la variación. La columna Series2 muestra las variaciones y como nuestro gráfico muestra solo valores positivos esta columna es el valor absoluto de la variación. La última columna Último Tope calcula el valor total de las dos columnas anteriores, esta es utilizada para graficar la siguiente variación.


Las formulas incluidas en cada columna son:

Para la columna Series1 utilizamos =SI(B3<0;E2+B3;E2). Aquí tenemos que tomar en cuenta dos condiciones, una si la variación es negativa y la otra si es positiva. En el caso de ser negativa tomamos el último tope, calculado en la fila anterior y le sumamos la variación (como esta es negativa es una resta). Esto nos dará el punto de partida de la variación. Si la variación es positiva solamente tomamos el último tope.

Para la columna Series2 utilizamos =ABS(B3) para obtener el valor absoluto. Esta columna es necesaria ya que no queremos graficar las variaciones negativas debajo del eje x sino que solo queremos reducir el valor sobre el cual graficamos la variación (este cálculo lo realizamos en la columna Series1).

Para la columna Último Tope utilizamos =E2+B3. Esta fórmula calcula el valor sobre el cual termina nuestra columna en el gráfico y se realiza en base al último valor más la variación.

Luego graficamos las columnas Series1 y Series2 y obtendremos un gráfico similar al siguiente.


El último paso es hacer las columnas de la serie 1 transparentes para lograr el efecto del gráfico de cascada. Para ello seleccionamos el gráfico y luego la ficha Formato del grupo Herramientas de Gráficos. Seleccionamos la Serie 1 de la lista desplegable Selección actual y finalmente seleccionamos Sin relleno de la lista desplegable.




Para acceder al archivo del ejemplo haga clic aquí.

No hay comentarios:

Publicar un comentario en la entrada